The URL https://easee.cloud is not working at the moment, Please use the URL https://portal.easee.com instead
Incident Report for Easee
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 09:40 CET
Investigating
The URL https://easee.cloud is not working at the moment, Please use the URL https://portal.easee.com instead

Problem with DNS routing.
Posted Jan 25, 2023 - 08:08 CET
This incident affected: Easee Portal.