Support Phone Line Issues

Incident Report for Easee

Postmortem

Issue was resolved by Telia

Posted Mar 10, 2026 - 19:17 CET

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 19:17 CET

Investigating

Some customers may currently experience issues reaching our support phone line due to an issue with our telephony provider. We will provide updates as new information becomes available.
Posted Mar 10, 2026 - 14:28 CET
This incident affected: External third party systems & Services (Phone Support).