Issues with latency

Incident Report for Easee

Resolved

The incident has been resolved.
Posted Jan 10, 2025 - 17:43 CET

Investigating

We are currently investigating an issue causing degraded performance across our cloud services.
Posted Jan 10, 2025 - 16:14 CET
This incident affected: Easee Cloud & API, Easee Portal and Easee Apps (Easee App, Installer app).